Project

General

Profile

提案 #1397

Ruby-GNOME 3.3.8を利用する

Added by Yuto Tokunaga 22 days ago. Updated 18 days ago.

Status:
終了
Priority:
通常
Assignee:
-
Target version:
プラグイン名:
gtk
ブランチ:
topic/1397-gtk2-338

Description

glib2 >= 2.62.0に対応したRuby-GNOME 3.3.8がリリースされました.
https://github.com/ruby-gnome/ruby-gnome/blob/f8be7c7b5752ddf83955bd9806a916e0b9dfbe90/NEWS#L5-L88
(※このリリースでプロジェクト名がRuby-GNOMEに変更されました.)

Ruby-GNOME2 3.3.7ではglib2 >= 2.62.0の環境下でglib2 gem(のnative extension)のビルドに失敗します.

Associated revisions

Revision dc60155c (diff)
Added by Yuto Tokunaga 21 days ago

gtk2 3.3.8 refs #1397

Revision 83529601 (diff)
Added by Yuto Tokunaga 18 days ago

gtk2 3.3.8 refs #1397

History

#1

Updated by Yuto Tokunaga 22 days ago

  • Status changed from パッチ適用待ち to レビュー待ち
  • Assignee deleted (Yuto Tokunaga)
  • ブランチ set to topic/1397-gtk2-338
#2

Updated by Yuto Tokunaga 21 days ago

  • Status changed from レビュー待ち to まだダメ

間違ったブランチをpushしてしまったので生やし直します.少しお待ち下さい.

#3

Updated by Yuto Tokunaga 21 days ago

topic/1397-gtk2-338にpush -fしました.

#4

Updated by Yuto Tokunaga 21 days ago

  • Status changed from まだダメ to レビュー待ち
#5

Updated by toshi_a 初音 21 days ago

みんなで2,3日使って様子を見てみましょう(雑)

#6

Updated by Izumi Tsutsui 20 days ago

pkgsrc 的には 9/15 に Ruby-GNOME 3.3.8 に上げていて、
https://social.mikutter.hachune.net/@tsutsuii/102792316823995706
その状態で mikutter の develop を2週間くらい使ってて特に落ちてないので、
過去の #1292#note-5 のようなあからさまな問題はないんじゃないかと思います。
(そういえば gi でセグるというのもあまり見ていないような)

#7

Updated by Yuto Tokunaga 19 days ago

二日くらい使ってますがクラッシュしてないです.

#8

Updated by toshi_a 初音 18 days ago

良さそう。金曜夜か土曜に develop にmergeしちゃいます。これ見た人が先にやってもいいよ。

#9

Updated by Yuto Tokunaga 18 days ago

  • Status changed from レビュー待ち to 終了

(見てしまった)mergeしました.

Also available in: Atom PDF