プロジェクト

全般

プロフィール

提案 #1292

gtk2 3.2.9を利用する

Akira Ouchi4ヶ月前に追加. 3ヶ月前に更新.

ステータス:
終了
優先度:
通常
担当者:
対象バージョン:
プラグイン名:
ブランチ:
topic/1292-gtk2-3.2.9

説明

ruby-gnome2 3.2.9がリリースされたので、3.2.9が利用できるか検証して適用する。
(なんかもう修正続きすぎてなにが治ったかはもうどうでも良くなった。)

gtk329.patch (245 Bytes) gtk329.patch Akira Ouchi, 2018-08-27 23:37

関連するチケット

関連している 環境対応 #1260: gtk2 3.2.7を利用する却下2018-06-06

関連している 環境対応 #1221: gtk2 3.2.5を利用する却下2018-05-03

関連している 環境対応 #1204: gtk2 3.2.4を利用する終了2018-04-09

関連している 環境対応 #1199: gtk2 3.2.3を利用する終了2018-04-04

関係しているリビジョン

リビジョン e661e121 (差分)
Akira Ouchi3ヶ月前に追加

gtk2 3.2.9を利用する refs #1292

履歴

#1 Akira Ouchi4ヶ月前に更新

#2 Akira Ouchi4ヶ月前に更新

#3 Akira Ouchi4ヶ月前に更新

#4 Akira Ouchi4ヶ月前に更新

#5 Izumi Tsutsui4ヶ月前に更新

ruby-gnome2 履歴

https://social.mikutter.hachune.net/@tsutsuii/100316837558431406

ruby-gnome2 3.2.2 以降の流れ
3.2.2: バグで一瞬で 3.2.3 が出たので未テスト
3.2.3: 非互換変更で起動しない https://github.com/ruby-gnome2/ruby-gnome2/issues/1154
3.2.4: 設定のスキンを開くと落ちる https://github.com/ruby-gnome2/ruby-gnome2/issues/1162
3.2.5: カーソル移動で警告が出続ける https://github.com/ruby-gnome2/ruby-gnome2/issues/1166
3.2.6: gem の依存関係がおかしくてすぐ 3.2.7 が出た
3.2.7: メモリリーク https://github.com/ruby-gnome2/ruby-gnome2/issues/1230
3.2.8 はいつ出るか

3.2.8 は #1260-14 の通り gem 作成バグでした

#6 Izumi Tsutsui3ヶ月前に更新

8/8 に pkgsrc に ruby-gnome2 3.2.9 を入れて常用していますが、メモリ使用量を含め特に問題ありません。
http://www.nerv.org/pkgsrc/?q=id:20180808T121602Z.aefe5a4682813ccd49d814e19b44c306bc5d7d3d

「メモリ使用量が減ることがある」というのが渡しにとっては斬新でした……

#7 cob odo3ヶ月前に更新

  • ステータスパッチ適用待ち から レビュー待ち に変更
  • 担当者Akira Ouchi にセット
  • ブランチtopic/1292-gtk2-3.2.9 にセット

topic/1292-gtk2-3.2.9 ブランチにpushしました。レビューお願いします。

#8 Akira Ouchi3ヶ月前に更新

  • ステータスレビュー待ち から マージ待ち に変更

(git logとdiffだけ確認して)問題ないです。
動作自体はチケット作成時から1ヶ月確認して問題なさそうなことを確認しています。

#9 cob odo3ヶ月前に更新

  • ステータスマージ待ち から 終了 に変更
  • 対象バージョン3.7 から 3.8 に変更

mergeしてpushしました。

他の形式にエクスポート: Atom PDF