Project

General

Profile

環境対応 #1221

gtk2 3.2.5を利用する

Added by Akira Ouchi over 1 year ago. Updated over 1 year ago.

Status:
却下
Priority:
通常
Assignee:
-
Target version:
Start date:
2018-05-03
Due date:
% Done:

0%

プラグイン名:
gtk

Description

#1211-10 の修正がruby-gnome2 3.2.5としてリリースされたので、これを利用するよう変更する。

3.2.5 NEWS
https://github.com/ruby-gnome2/ruby-gnome2/blob/3.2.5/NEWS


Files


Related issues

Related to 提案 #1292: gtk2 3.2.9を利用する終了Actions

History

#1

Updated by Akira Ouchi over 1 year ago

わたしの環境では3.2.5適用後問題なく動きはしているっぽいですが、デバッグモードで見ると
ウィンドウ内をカーソル移動した分だけ以下のメッセージが出力されていて、他のメッセージが埋もれていきます。

/Users/akkie/mikutter/core/lib/uithreadonly.rb:22: warning: GRClosure invoking callback: already destroyed: (anonymous)
/Users/akkie/mikutter/core/mui/cairo_cell_renderer_message.rb:64: warning: GRClosure invoking callback: already destroyed: (anonymous)
/Users/akkie/mikutter/core/mui/cairo_cell_renderer_message.rb:73: warning: GRClosure invoking callback: already destroyed: (anonymous)

#2

Updated by toshi_a 初音 over 1 year ago

再現しました。常用は難しそうですね。

#3

Updated by Izumi Tsutsui over 1 year ago

pkgsrc 環境でも再現しました。

ということなので ruby-gnome2 に issue 投げてみます。

https://github.com/ruby-gnome2/ruby-gnome2/issues/372
あたりで過去に似たような問題が出ているので、わかる人が見ればすぐ直るのかも……。

#4

Updated by Izumi Tsutsui over 1 year ago

ということなので ruby-gnome2 に issue 投げてみます。

https://github.com/ruby-gnome2/ruby-gnome2/issues/1166

#5

Updated by Izumi Tsutsui over 1 year ago

こちらに書くのを忘れてましたが、 ruby-gnome2 側に修正入りました。
https://github.com/ruby-gnome2/ruby-gnome2/commit/e11ae27581af70fb09ce26ef038d8ebfac49047a

なお、このあとのコミットでも小修正入っています。
https://github.com/ruby-gnome2/ruby-gnome2/commit/e77f03b60045c40b9851cc9ef5195c168c674fd0

現状 ruby-gnome2 に大量にコミットが入っているので、 3.2.6 はもう少しかかるのかも?
https://github.com/ruby-gnome2/ruby-gnome2/commits/master

#6

Updated by Akira Ouchi over 1 year ago

  • Status changed from 新規 to 却下

gtk2 3.2.6が出たのでそちらのチケットに移動します。

#7

Updated by Akira Ouchi about 1 year ago

Also available in: Atom PDF