Project

General

Profile

バグ #821

OAuth gem 0.5.0以上を使っていると、Twitterアクセストークンを取ることが出来ない

Added by toshi_a 初音 over 4 years ago. Updated over 4 years ago.

Status:
終了
Priority:
通常
Target version:
プラグイン名:
ブランチ:
クラッシュする:

Description

Ubuntu 15.04に、git cloneしたmikutterにbundleで依存gemを入れた場合、コマンドラインまたはGUI上からTwitter OAuthトークンを取得するときに以下のようなエラーが発生する

notice: {MIKUTTER_DIR}/core/boot/delayer.rb:37:in `block in terminate': undefined method `blank?' for nil:NilClass
from {MIKUTTER_DIR}/vendor/bundle/ruby/2.1.0/gems/oauth-0.5.0/lib/oauth/tokens/request_token.rb:29:in `build_authorize_url'

[[https://rubygems.org/gems/oauth/versions/0.5.0]] によると:

0.5.0 - February 20, 2016 (42.5 KB)
0.4.7 - September 4, 2012 (49.5 KB)

めっちゃ久しぶりにアップデートされていて、0.5を使った場合にこの問題が起こる。同じ環境で0.4.7にした場合はトークンを取得できた。
mikutterのGemfileのoauth gemのバージョン指定は~> 0.4なので、新規インストールだと0.5が入る。

まずはOAuth 0.4.7を強制して不具合を回避し、oauth 0.5がおそらくActiveSupportがあることを前提にしているのでそちらのバグを修正、それがリリースされた段階でもう一度mikutterのGemfileを書き換えて対応、という手順を取る

#1

Updated by toshi_a 初音 over 4 years ago

  • Status changed from 新規 to 実装待ち

すでに修正されていて、リリース待ちな模様

@toshi_a oauth gemのver.5.0.0でOAuth::RequestToken#authorize_urlが壊れてることが原因だと思います。アップストリームで修正されてますが新しいリリースがまだ出てません。

https://twitter.com/midchildan/status/703025865119010817
#2

Updated by Izumi Tsutsui over 4 years ago

toshi_a 初音 さんは書きました:

すでに修正されていて、リリース待ちな模様

すでに 0.5.1 出ていて、そちらでは修正されているっぽいです
https://github.com/oauth-xx/oauth-ruby/releases

#3

Updated by toshi_a 初音 over 4 years ago

  • Target version changed from 3.3 to 3.4

おー、いつのまにやら。mikutter 3.4からはoauth gem 0.5.1以降を要求するようにします

#4

Updated by toshi_a 初音 over 4 years ago

  • Status changed from 実装待ち to 終了

Also available in: Atom PDF