Project

General

Profile

Actions

バグ #1582

closed

ruby 2.7.5 で YAML.safe_load_file がなくてクラッシュする

Added by Shibafu Midorino 8 months ago. Updated 8 months ago.

Status:
終了
Priority:
通常
Target version:
プラグイン名:
ブランチ:
topic/1582-update-psych
クラッシュする:
Yes

Description

下記の環境にて、develop 8c17e266 が起動できません。YAML.safe_load_file は ruby 2.7.5 にバンドルされているよりも新しいバージョンの psych にしか存在しないようです。

  • ruby 2.7.5p203 (2021-11-24 revision f69aeb8314) [x86_64-darwin20]
  • macOS 11.6.2
I, [2022-01-23T09:55:42.045387 #18102]  INFO -- {MIKUTTER_DIR}/core/configloader.rb:43:in `boot': load setting data from /Users/shibafu/profiles/face/settings/setting.yml
Traceback (most recent call last):
    14: from mikutter.rb:29:in `<main>'
    13: from /Users/shibafu/git/mikutter/core/boot/option.rb:24:in `parse'
    12: from /Users/shibafu/git/mikutter/core/boot/option.rb:24:in `new'
    11: from /Users/shibafu/.rbenv-x64/versions/2.7.5/lib/ruby/2.7.0/optparse.rb:1093:in `initialize'
    10: from /Users/shibafu/git/mikutter/core/boot/option.rb:63:in `block in parse'
     9: from /Users/shibafu/git/mikutter/core/boot/option.rb:63:in `require'
     8: from /Users/shibafu/git/mikutter/core/boot/prepare_plugin.rb:4:in `<top (required)>'
     7: from /Users/shibafu/git/mikutter/core/boot/prepare_plugin.rb:4:in `require'
     6: from /Users/shibafu/git/mikutter/core/miquire_plugin.rb:3:in `<top (required)>'
     5: from /Users/shibafu/git/mikutter/core/miquire_plugin.rb:3:in `require'
     4: from /Users/shibafu/git/mikutter/core/plugin.rb:4:in `<top (required)>'
     3: from /Users/shibafu/git/mikutter/core/plugin.rb:4:in `require'
     2: from /Users/shibafu/git/mikutter/core/configloader.rb:20:in `<top (required)>'
     1: from /Users/shibafu/git/mikutter/core/configloader.rb:120:in `<module:ConfigLoader>'
/Users/shibafu/git/mikutter/core/configloader.rb:44:in `boot': undefined method `safe_load_file' for Psych:Module (NoMethodError)
Did you mean?  safe_load
Actions

Also available in: Atom PDF