Project

General

Profile

Actions

バグ #1549

closed

addressable と gettext の gem バージョン

Added by Izumi Tsutsui over 2 years ago. Updated over 2 years ago.

Status:
却下
Priority:
通常
Target version:
プラグイン名:
ブランチ:
クラッシュする:
No

Description

  • source:Gemfile@146abc89
    gem 'addressable','>= 2.7.0', '< 2.8'
    になっていますが、すでに addressable 2.8.0 が出ているので diva 同様 < 3.0 でよいのでは
  • source:plugin/uitranslator/Gemfile@146abc89
    gem 'gettext', '>= 3.3.5', '< 3.4'
    になっていますが gettext 3.4.1 まで出ているので、これも < 4.0 でよいのでは。
    あと develop の f1ed187d では >= 3.3.6 になってるので合わせてしまってよいと思います。
    f1ed187d の他の更新もマージすべきかもしれませんが、残り gtk2 と test 関連なので微妙)

Files

0001-gem-dependencies.patch (1.18 KB) 0001-gem-dependencies.patch Izumi Tsutsui, 2021-12-04 06:20

Related issues

Related to 提案 #1550: 依存gemのバージョン変更 (5.0)終了toshi_a 初音Actions
Actions #1

Updated by Izumi Tsutsui over 2 years ago

パス間違えてました……。
そのままの雑パッチ添付。

Actions #2

Updated by toshi_a 初音 over 2 years ago

  • Status changed from パッチ適用待ち to 却下
  • Assignee set to toshi_a 初音

mikutterでは多くのライブラリをロードしていて複雑な問題が度々起きていたので、addressableなどのちゃんとsemverしているライブラリはマイナーバージョンを指定します。
とはいえdevelop (gtk3) ブランチで古いのは不便だと思うのでパッチは受け入れませんが提案には対応したいです。というかそろそろ5.0出すのでやったほうがいいですね。

divaなどのライブラリについては、ライブラリはできるだけ広く対応バージョンを取っておくべきであること、十分なテストが書かれていることから、同様のパッチを受け入れています。

Actions #3

Updated by toshi_a 初音 over 2 years ago

  • Related to 提案 #1550: 依存gemのバージョン変更 (5.0) added
Actions

Also available in: Atom PDF