Project

General

Profile

バグ #1412

plugin/uitranslator/Gemfile が irb >=1.2.0 を要求している

Added by Izumi Tsutsui about 2 months ago. Updated about 2 months ago.

Status:
終了
Priority:
通常
Assignee:
Target version:
プラグイン名:
uitranslator
ブランチ:
topic/1412-delete-irb-dependency
クラッシュする:
No

Description

バグというより change request ですが

source:plugin/uitranslator/Gemfile

  gem 'irb', '>= 1.2.0', '< 1.3'

が指定されていますが、
ruby 2.5 にバンドルされている irb は 0.9.6
ruby 2.6 にバンドルされている irb は 1.0.0
ruby 2.7 にバンドルされている irb は 1.2.0
rubygems にある最新版の irb は 1.2.1
ということらしいので、 ruby 2.6 以下の状態で mikutter 4.0.0 を起動すると
bundle で irb 1.2.1 を取得する動作になってしまいます。

そもそも irb を明示的に指定する必要があるのかどうかもわかっていませんが
0.9.6 でも許容するようにできないか検討をお願いします。

参考
https://twitter.com/_taca_/status/1209818971739803649

@tsutsuii % uname -sr
NetBSD 9.0_RC1
% irb26
irb(main):001:0> IRB.version
=> "irb 1.0.0 (2018-12-18)"
irb(main):002:0> quit
% irb25
irb(main):001:0> IRB.version
=> "irb 0.9.6(09/06/30)"

なので、差し支えなければ0.9.6以上にしといてくれると良かったのですけどねぇ。

Also available in: Atom PDF