Project

General

Profile

Actions

提案 #1330

closed

使用しているライブラリのバージョンを上げる

Added by Izumi Tsutsui over 2 years ago. Updated over 2 years ago.

Status:
終了
Priority:
通常
Assignee:
Target version:
プラグイン名:
ブランチ:
topic/1330-update-gems

Description

2019/1/18 という少し前ですが、
addressable の gem の 2.6.0 がリリースされています。
https://github.com/sporkmonger/addressable/blob/addressable-2.6.0/CHANGELOG.md

mikutter および diva の gem だと、 addressable に対して以下の通り 2.6 未満の指定がされています。

source:Gemfile@a899bf32#L15

  gem 'addressable', '>= 2.5.2', '< 2.6'

https://github.com/toshia/diva/blob/v0.3.2/diva.gemspec#L27

 spec.add_dependency "addressable", ">= 2.5", "< 2.6"

addressable gem のコミットログを見る限り、
2.5.2 → 2.6.0 へ minor バージョンが上げられたのは
ruby 2.6 サポートと bundle 2.x のサポートという気がします。
過去の minor bump を見ても ruby のバージョン絡みのみっぽいので、
とりあえず <3.0 指定でもいいんじゃないかという気がします。

手元で試したところでは mikutter 3.8.7 + diva 0.3.2 で
addressable 2.6.0 でもTLを眺めるのに支障がないくらいには
動いているようです。
(addressable gem がどこで参照されるのかを把握していない)

……という方針のパッチをとりあえず添付します。
0001-Relax-required-version-of-addressable-gem.patch


Files


Related issues

Copied to 提案 #1400: addressable gem 2.7.0 対応終了Actions
Actions

Also available in: Atom PDF