Project

General

Profile

環境対応 #1146

Pango::UNDERLINE_SINGLE' has been deprecated が出ている

Added by Izumi Tsutsui over 1 year ago. Updated over 1 year ago.

Status:
終了
Priority:
通常
Assignee:
Target version:
Start date:
2018-01-02
Due date:
% Done:

0%

プラグイン名:

Description

題名のとおりですが、以下の警告が出ているようです。(適当に折り返しています)

warning: /usr/pkg/lib/ruby/gems/2.3.0/gems/glib2-3.2.1/lib/glib2/deprecatable.rb:123:in `const_missing': \
{MIKUTTER_DIR}/core/mui/gtk_intelligent_textview.rb:124:in `create_tag_ifnecessary': \
'Pango::UNDERLINE_SINGLE' has been deprecated. Use 'Pango::Underline::SINGLE' or ':single'.

pango は Ruby-GNOME2 に含まれていて Gemfile では ruby gtk2 3.2.0 以降を指定しているので、
言われるがままに
'Pango::UNDERLINE_SINGLE' → 'Pango::Underline::SINGLE'
の置き換えでいけるっぽいです。
gtk_intelligent_textview.rb.diff


Files

gtk_intelligent_textview.rb.diff (594 Bytes) gtk_intelligent_textview.rb.diff Izumi Tsutsui, 2018-01-02 13:38

Related issues

Related to 環境対応 #1041: gtk2 3.1.6を使用する終了2017-05-16

Actions

Associated revisions

Revision 3df75d5c (diff)
Added by あひる 家鴨 over 1 year ago

Pango::UNDERLINE_SINGLE を Pango::Underline::SINGLE に変更 refs #1146

UNDERLINE_SINGLE は deprecated

History

#1

Updated by toshi_a 初音 over 1 year ago

#1041 の対応漏れみたいですね。

#2

Updated by toshi_a 初音 over 1 year ago

#3

Updated by Izumi Tsutsui over 1 year ago

  • Status changed from 新規 to パッチ適用待ち

1行パッチなので様子見でステータス更新しときます

#4

Updated by あひる 家鴨 over 1 year ago

  • Status changed from パッチ適用待ち to レビュー待ち
  • Assignee set to Izumi Tsutsui

topic/1146-fix-pango-deprecated ブランチにdiffを適用しました。
私の環境では deprecated がでなくなりました。
確認をお願いします。

#5

Updated by Izumi Tsutsui over 1 year ago

topic/1146-fix-pango-deprecated をチェックアウトして
--debug 付きで起動した場合に deprecated が出なくなっていることを確認しました。

チケットの「ステータス」の選択肢として「解決」「まだダメ」「終了」「却下」しかなくて
「マージ待ち」に変更できないようですが、「環境対応」だからでしょうか。

#6

Updated by toshi_a 初音 over 1 year ago

そうですね。話が逸れちゃいますが、Wikiに書いてあるのはバグチケットの処理手順なので、ここでは当てはまりません。

#7

Updated by あひる 家鴨 over 1 year ago

  • Status changed from レビュー待ち to 終了

master に merge しました。

Also available in: Atom PDF