Project

General

Profile

致命的 #608

bundle installでgemを導入した場合、不適切なgettextが入る

Added by Satoshi Okuno about 6 years ago. Updated almost 6 years ago.

Status:
終了
Priority:
通常
Target version:
Start date:
2013-09-07
Due date:
% Done:

0%

プラグイン名:

Description

一週間前くらいにgemのgettextが3.0.0にメジャーバージョンアップしたらしく、APIが変わったようです。
ので、そのままbundle installして3.0.0を導入すると、mikutterが例外を吐いて起動しない事態になっています。
(直接の原因はcreate_pofiles()が無くなったからみたいです。)

Gemfileに2.x.x系を取ってくる様にバージョン指定する事で回避出来ました。

developに対するパッチを添付しますので、マージご検討下さい。


Files

0001-GetText.patch (1.33 KB) 0001-GetText.patch Satoshi Okuno, 2013-09-07 22:27

History

#1

Updated by toshi_a 初音 almost 6 years ago

  • Status changed from 新規 to 終了
  • Assignee set to toshi_a 初音
  • Target version changed from 0.2.2 to 3.0.0

見逃していました、申し訳ございません。
チケット #611 と同じ問題ですね。こちらについては、 #611 のコメントの通り、gettext3に対応することで対応しました。

Also available in: Atom PDF