Project

General

Profile

Actions

バグ #1507

closed

Lets EncryptのCA証明書の期限切れ

Added by toshi_a 初音 14 days ago. Updated 14 days ago.

Status:
終了
Priority:
通常
Target version:
プラグイン名:
ブランチ:
topic/1507-httpclient-cacrt
クラッシュする:
No

Description

9/30から、Lets EncryptのCA証明書の期限切れが原因でmikutterがLets Encryptを使っているMastodonサーバに接続できなくなっている。
原因は、httpclientが独自に証明書をもっていて、このgemの最終リリースの2016年から証明書が更新されていないこと。

https://github.com/nahi/httpclient/issues/445

10/1時点で証明書が更新されたhttpclientのリリースが打たれていれば単純にアップデートしようと思っていたが、現時点でリリースが打たれていない状況なので、一旦上記issueにかかれているワークアラウンドを試す。

Actions #1

Updated by toshi_a 初音 14 days ago

  • Status changed from 実装待ち to レビュー待ち
  • ブランチ set to topic/1507-httpclient-cacrt
Actions #2

Updated by toshi_a 初音 14 days ago

  • Status changed from レビュー待ち to 終了

merged.

Actions

Also available in: Atom PDF