Project

General

Profile

バグ #1069

bundlerを使ってGemをインストールする時、pluginグループを除外してもプラグインの要求するGemがインストールされる。

Added by toshi_a 初音 almost 3 years ago. Updated almost 3 years ago.

Status:
却下
Priority:
通常
Assignee:
-
Target version:
プラグイン名:
ブランチ:
クラッシュする:

Description

次のようにしても、例えばgtk2などのプラグインがインストールされてしまっている。

bundle install --without plugin

理由は、プラグインのGemfileでロードされる物をpluginグループに所属させる処理が、最近のBundlerでは期待通り動いていないから。


Related issues

Blocks バグ #1054: bundle installをしても一部のGemがインストールされない実装待ち2017-06-30Actions

Also available in: Atom PDF