Project

General

Profile

バグ #1048

mikutterがRuby/Gtk2のビルドに失敗するバージョンを要求している

Added by At Nanasi over 2 years ago. Updated over 2 years ago.

Status:
終了
Priority:
通常
Assignee:
Target version:
プラグイン名:
ブランチ:
クラッシュする:

Description

こんにちは、初めて投稿します。

mikutterの開発版を試そうととmikutterのルートフォルダで

bundle install --path vendor/bundle

を実行したところ、Ruby/Gtk2のNative extensionsのビルドに失敗してしまいました。
色々試したもののビルドが通る事はなかったため、Ruby/Gtk2のIssuesを確認したところ、次のようなIssueを見つけました。

https://github.com/ruby-gnome2/ruby-gnome2/issues/1018

これによると3.1.2で修正されたようなのでGemfileを編集し、Ruby/Gtk2のバージョンを3.1.2に上げたところ、正常にビルドする事ができました。

環境ですが、ArchLinux Ruby 2.4.1です。
よろしくお願いします。


Related issues

Is duplicate of 環境対応 #1041: gtk2 3.1.6を使用する終了2017-05-16

Actions

History

#1

Updated by toshi_a 初音 over 2 years ago

#2

Updated by toshi_a 初音 over 2 years ago

  • Assignee set to At Nanasi

既に #1041 で進行中しています。こちらのブランチの内容でビルドできるか試してみてください。

#3

Updated by At Nanasi over 2 years ago

topic/1041-ruby-gnome2-3.1.6 で確かにビルドを通る事を確認しました。動作も今のところは問題ないようです。

#4

Updated by toshi_a 初音 over 2 years ago

  • Status changed from 新規 to 終了

hotfix/3.5にmergeしました。

Also available in: Atom PDF