Project

General

Profile

致命的 #124

Ubuntu 11.04(natty)に含まれるruby-gnome2パッケージで、PINコード入力直後にクラッシュする

Added by toshi_a 初音 over 8 years ago. Updated over 8 years ago.

Status:
終了
Priority:
通常
Target version:
-
Start date:
2011-04-30
Due date:
% Done:

0%

プラグイン名:
change_account

Description

ubuntu 11.04のリポジトリに入っているruby-gnome2パッケージのrubygtkだと、ある環境下では以下のようなコードでセグメンテーションフォールトを起こすことがある

Gtk::Window.toplevels.first.show

回避策としては、Gtk::Window.toplevelsをmikutter内では一切つかわないようにする。

History

#1

Updated by toshi_a 初音 over 8 years ago

  • Status changed from 新規 to 終了

get_windowフィルタで代用できた。今後、nattyが消えるまでにこのメソッドが必要なケースが出てきた場合は、ObjectSpaceなどで代用する必要があるかも知れない。

Also available in: Atom PDF