プロジェクト

全般

プロフィール

機能 #751

Enamerator.newのdeprecation warning対応

コスモ 虹川2年以上前に追加. 約2年前に更新.

ステータス:
終了
優先度:
通常
対象バージョン:
開始日:
2015-01-25
期日:
進捗率:

100%

プラグイン名:
gtk

説明

新しめのRubyを使うと以下のような警告が出るようになっていました、

mikutter/core/mui/gtk_inneruserlist.rb:30:
warning: Enumerator.new without a block is deprecated; use Object#to_enum

これは単純にobj.to_enumすれば良いだけのようです。

0001-Fix-deprecation-warning-Enumerator.new-without-block.patch 表示 (1.06 KB) コスモ 虹川, 2015-01-25 15:10

関係しているリビジョン

リビジョン 0803d108 (差分)
コスモ 虹川約2年前に追加

Enumerator.newのdeprecation warning対応 refs #751

履歴

#1 toshi_a 初音約2年前に更新

  • ステータス新規 から レビュー待ち に変更
  • 進捗率0 から 100 に変更

ありがとうございます。出なくなったようです。

#2 コスモ 虹川約2年前に更新

確認しました。大丈夫だと思います。ヽ('ω')ノ三ヽ('ω')ノ

#3 toshi_a 初音約2年前に更新

  • ステータスレビュー待ち から 終了 に変更

他の形式にエクスポート: Atom PDF