プロジェクト

全般

プロフィール

バグ #1048

mikutterがRuby/Gtk2のビルドに失敗するバージョンを要求している

At Nanasi7ヶ月前に追加. 6ヶ月前に更新.

ステータス:
終了
優先度:
通常
担当者:
対象バージョン:
プラグイン名:

説明

こんにちは、初めて投稿します。

mikutterの開発版を試そうととmikutterのルートフォルダで

bundle install --path vendor/bundle

を実行したところ、Ruby/Gtk2のNative extensionsのビルドに失敗してしまいました。
色々試したもののビルドが通る事はなかったため、Ruby/Gtk2のIssuesを確認したところ、次のようなIssueを見つけました。

https://github.com/ruby-gnome2/ruby-gnome2/issues/1018

これによると3.1.2で修正されたようなのでGemfileを編集し、Ruby/Gtk2のバージョンを3.1.2に上げたところ、正常にビルドする事ができました。

環境ですが、ArchLinux Ruby 2.4.1です。
よろしくお願いします。


関連するチケット

次のチケットと重複 環境対応 #1041: gtk2 3.1.6を使用する終了2017-05-16

履歴

#1 toshi_a 初音6ヶ月前に更新

#2 toshi_a 初音6ヶ月前に更新

  • 担当者At Nanasi にセット

既に #1041 で進行中しています。こちらのブランチの内容でビルドできるか試してみてください。

#3 At Nanasi6ヶ月前に更新

topic/1041-ruby-gnome2-3.1.6 で確かにビルドを通る事を確認しました。動作も今のところは問題ないようです。

#4 toshi_a 初音6ヶ月前に更新

  • ステータス新規 から 終了 に変更

hotfix/3.5にmergeしました。

他の形式にエクスポート: Atom PDF