プロジェクト

全般

プロフィール

最適化 #928

direct_messageプラグインでPlugin::GUI::Fragment#user is deprecatedのnoticeが出力される

Akira Ouchi11ヶ月前に追加. 11ヶ月前に更新.

ステータス:
終了
優先度:
通常
担当者:
対象バージョン:
開始日:
2016-11-12
期日:
進捗率:

0%

プラグイン名:
direct_message

説明

direct_messageプラグインでdeprecatedになったuserが使われていると出力されていました。

notice: {MIKUTTER_DIR}/core/configloader.rb:32:in `block in <module:ConfigLoader>': configloader: wrote 2 keys (UserConfig::ui_tab_order, UserConfig::profile_opened_tabs)
warning: /Users/akkie/.rbenv/versions/2.3.1/lib/ruby/2.3.0/rubygems/deprecate.rb:62:in `block (2 levels) in deprecate': NOTE: Plugin::GUI::Fragment#user is deprecated; use retriever instead. It will be removed on or after 2017-02-01.

http://dev.mikutter.hachune.net/projects/mikutter/repository/entry/core/plugin/direct_message/direct_message.rb?utf8=%E2%9C%93&rev=develop#L22

userをretrieverに書き換えてnoticeが消えることを確認しています。

関係しているリビジョン

リビジョン 92419bee (差分)
toshi_a 初音11ヶ月前に追加

direct_message: deprecatedなメソッドを使わない refs #928

履歴

#1 Akira Ouchi11ヶ月前に更新

  • トラッカーバグ から 最適化 に変更

#2 toshi_a 初音11ヶ月前に更新

  • ステータス新規 から 進行中 に変更
  • 担当者toshi_a 初音 にセット

#3 toshi_a 初音11ヶ月前に更新

  • ステータス進行中 から 終了 に変更

他の形式にエクスポート: Atom PDF