プロジェクト

全般

プロフィール

機能 #645

起動時にBundlerを使用するかどうかを選択できる仕組みを入れる

toshi_a 初音3年以上前に追加. 約3年前に更新.

ステータス:
終了
優先度:
通常
担当者:
対象バージョン:
開始日:
2014-03-11
期日:
進捗率:

0%

プラグイン名:

説明

mikutter.rb の L16 - L22の、Bundler使うかどうか判断しているところがあるが、GentooとDebianのパッケージを作る時に問題になるという報告があった。

begin
  ENV['BUNDLE_GEMFILE'] = File.expand_path(File.join(File.dirname($0), "Gemfile"))
  require 'bundler/setup'
rescue LoadError, SystemExit
  # bundlerがないか、依存関係の解決に失敗した場合
  # System の gem を使ってみる
end

この部分を実行するかどうかを、環境変数か、起動オプションで切り替えられるようにしてみる

関係しているリビジョン

リビジョン d2d55a4c (差分)
toshi_a 初音3年以上前に追加

環境変数 DISABLE_BUNDLER_SETUP を空にセットすることで、bundlerを読みに行く挙動を抑制できるようにした refs #645

リビジョン 1e49a0b7 (差分)
toshi_a 初音約3年前に追加

環境変数 DISABLE_BUNDLER_SETUP を空にセットすることで、bundlerを読みに行く挙動を抑制できるようにした refs #645

履歴

#1 toshi_a 初音3年以上前に更新

  • ステータス新規 から 進行中 に変更

#2 toshi_a 初音約3年前に更新

http://twitter.com/naota344/status/476619106519498752
すごくよかったとのことなのでさっさと反映する

#3 toshi_a 初音約3年前に更新

  • ステータス進行中 から 終了 に変更

他の形式にエクスポート: Atom PDF