プロジェクト

全般

プロフィール

環境対応 #1146

Pango::UNDERLINE_SINGLE' has been deprecated が出ている

Izumi Tsutsui17日前に追加. 12日前に更新.

ステータス:
新規
優先度:
通常
担当者:
-
対象バージョン:
開始日:
2018-01-02
期日:
進捗率:

0%

プラグイン名:

説明

題名のとおりですが、以下の警告が出ているようです。(適当に折り返しています)

warning: /usr/pkg/lib/ruby/gems/2.3.0/gems/glib2-3.2.1/lib/glib2/deprecatable.rb:123:in `const_missing': \
{MIKUTTER_DIR}/core/mui/gtk_intelligent_textview.rb:124:in `create_tag_ifnecessary': \
'Pango::UNDERLINE_SINGLE' has been deprecated. Use 'Pango::Underline::SINGLE' or ':single'.

pango は Ruby-GNOME2 に含まれていて Gemfile では ruby gtk2 3.2.0 以降を指定しているので、
言われるがままに
'Pango::UNDERLINE_SINGLE' → 'Pango::Underline::SINGLE'
の置き換えでいけるっぽいです。
gtk_intelligent_textview.rb.diff

gtk_intelligent_textview.rb.diff (594 Bytes) gtk_intelligent_textview.rb.diff Izumi Tsutsui, 2018-01-02 13:38

関連するチケット

関連している 環境対応 #1041: gtk2 3.1.6を使用する終了2017-05-16

履歴

#1 toshi_a 初音12日前に更新

#1041 の対応漏れみたいですね。

#2 toshi_a 初音12日前に更新

他の形式にエクスポート: Atom PDF